R7-4 两个有序链表序列的合并
已知两个非降序链表序列S1与S2,设计函数构造出S1与S2合并后的新的非降序链表S3。
输入格式:
输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。
输出格式:
在一行中输出合并后新的非降序链表,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL
。
输入样例:
1 3 5 -1
2 4 6 8 10 -1
输出样例:
1 2 3 4 5 6 8 10
#include <iostream>
#include <list>
#include <algorithm>
using namespace std;
int main() {
list<int> list1, list2;
int value;
while (cin >> value && value != -1) {
list1.push_back(value);
}
while (cin >> value && value != -1) {
list2.push_back(value);
}
list1.merge(list2);
if (list1.empty()) {
cout << "NULL" << endl;
} else {
for (auto it = list1.begin(); it != list1.end(); ++it) {
cout << *it << (it != prev(list1.end()) ? " " : "");
}
cout << endl;
}
return 0;
}